欢迎来访实搜网站库!

蓝色 学校 微商 大气 企业

dede后台登陆验证码错误

时间:2015-07-17 10:55
dede 后台登陆验证码错误,其中一个问题大家可能忽略,dede所用的php版本与空间商的php版本不同造成的。更改空间商的php版本就可以了。 自己也建了一个网站,建站

 

dede 后台登陆验证码错误,其中一个问题大家可能忽略,dede所用的php版本与空间商的php版本不同造成的。更改空间商的php版本就可以了。

 

自己也建了一个网站,建站过程中在老李这里学了很多东西,所以想把自己最近遇到的问题;

 

dede后台登陆验证码错误及解决方案奉献到这里,算是对老李的回报吧。 之前我的网站都很正常,最近遇到dede后台登陆验证码错误的问题,不只是后台,其他网页的验证码都出现问题了,在网上查资料整了好几天,总结如下: 

 

(1)检查虚拟主机的空间是否足够.(不可行,因为我的虚拟主机没有问题)。 

 

(2)可能是由于缓存的原因造成后台验证码错误无法登陆。使用用ftp把data/session目录下除index.htm外的其它session文件都删除,然后本地ie浏览器清除缓存。(不可行) 

 

(3)data/safe/inc_safe_config.php打开头一行,$safe_gdopen = '1,2,3,4,5,6'; 修改为 $safe_gdopen = '1,2,3,4,5'; 去掉6,即关闭后台验证码选项。(可行,验证码不起作用了,心里不舒服)。 

 

(4)dede 系统重装,(不可行) 

 

(5)系统备份恢复(不可行) 

 

(6)数据库恢复(不可行) 

 

(7)网上说的修改common.func.php文件(不可行) 

 

(8)修改php.ini中的 sessions.cookie_path (不可行,空间商不让修改); 

 

(9)按照(3)登陆后,在系统——验证安全设置——开启系统验证码, 去掉后台登陆以及其他如会员登陆,会员注册等,(可行,跟(3)作用一样,验证码不起作用,像自己身上长了一个疮,盖了一块布,不让别人看到一样,心里难受) 

 

(10)data/session 权限,修改为777(不可行) 

 

(11)降低空间商(godaddy)php 版本,由5.4.23降到5.2.17 (可行),问题彻底解决,估计最近空间商更新了系统,新版本的php与dede有些设置不兼容。这一点大家可能容易忽略。 希望我的经历可以给大家提供点有用的信息。